Preparser error after new upgrade

Topics: IRIS in General
Jun 11, 2014 at 8:14 PM
Hi guys, after updating IRIS today I am getting the following error when loading a model file
Warning: IRIS Toolbox Warning @ preparser:controls.
*** Error preparsing file(s) FF.model. This is obsolete syntax, and will be removed from a future version of IRIS. Use pseudosubstitution syntax $[...]$ instead.
Do you know what might be causing this error?

Thanks!

Hector
Coordinator
Jun 11, 2014 at 8:25 PM
Edited Jun 11, 2014 at 8:29 PM
This is actually just a warning. Also, it's incomplete (my mistake) -- it does not show the relevant piece of code, sorry about that.

You use [ ... ] in the !for loop to evaluate an expression and use it as tokens in the body of the loop. Simply replace this with $[ ... ]$. This is now unified syntax that can also be used outside the !for loop. You have plenty of time to make the changes. The old syntax will stay in IRIS for a couple of months at least.

Sorry about the inconvenience.

Jaromir
Marked as answer by jaromirbenes on 6/11/2014 at 1:28 PM
Jun 11, 2014 at 8:26 PM
Thanks for the quick clarification!

Hector