This project is read-only.

Old version of IRIS

Topics: IRIS in General
Jun 7, 2014 at 8:00 AM
Where I can download old version of IRIS 20140315? (link please)

How I can know in which version of IRIS is written a program, if is not specificated?
Jun 7, 2014 at 2:51 PM
Edited Jun 7, 2014 at 5:10 PM
As far as I know there was no official release at 20140315 (you may check them out in Downloads section of this project).

And I'd strongly recommend you to use the latest version of IRIS Toolbox since one you are looking for was most probably released not so long ago and not so many adjustments (if any) you will need to make in your codes. Should you have any problems adjusting your codes all the community will be happy helping you.
Jun 7, 2014 at 3:44 PM
Please, help me, I'am beginner in IRIS programing. I urgently need to estimate a DSGE model. It is too important for me. I have the code and the data. I don't know in how version of IRIS it can work. Yesterday comand read_model(p) worked, today did not. I am confused. I can't link the data to model. I read tutorial and I do the same, but my model not work. If anyone can show my code and data and help me, will be happy, really happy!
Jun 7, 2014 at 5:28 PM
Hm.. There's no command read_model in IRIS, so most probably it's just a one of scripts you were provided together with a model file. In that case you just need to find that script and make sure Matlab knows where it is located (help addpath).

This should not be caused by a "wrong" IRIS version, so you may use last official release.
Jun 7, 2014 at 5:36 PM

As Sergey says, get the latest version. The model you have is written in a version about ten years old, that is the actual problem.

Make the corrections I suggested last time. If you still have problems post the corrected codes again.

But my primary advice is -- you should never run someone else's model files if you do not understand them and if you're not able to write them by yourself.

Jun 7, 2014 at 6:13 PM
I I made all the recomanded changes. I don't understand , why yesterday my model was good. The command read_model(p) worked, today did not.


ans =
   Beta_p: 0.9925
   Beta_i: 0.9650

m = read_model(p)

Flag=0 ... A shift in markups

m =
non-linear model object: [1] parameterisation(s)
number of equations: [15 98]
solution(s) available: [1] parameterisation(s)
comment: 'doplnit popisky a hp filter a zkontrolovat allbut'
user data: [1x1 struct]
I don't understand the nature of the problem? What changed? Yerstarday I instaleed a new version of IRIS, without restart, as result model worked.
What could it be?
if you want to analyze I can be send the code.

Jun 7, 2014 at 6:26 PM
This is the code Tell me please, it is a chance to run it? Thank you!
Jun 7, 2014 at 6:59 PM
Edited Jun 7, 2014 at 7:00 PM
I need a version of IRIS Toolbox in which the comand read_model(p) is avaible. p contain the variable from steady-state, deppending on it the model is solved.
I do not know what is happening today with me (:) Yesterday I found the old version in IRIS site at (downloads), today there is only version since 2014.
Jun 7, 2014 at 8:00 PM
Read_model is NOT an IRIS command. It is an m-file created by someone who wrote that particular model. Please distinguish between IRIS functions and application m-files. In Matlab and IRIS you always write a lot of your own m-files that use Matlab and IRIS functions but are not part of Matlab or IRIS.

Jun 7, 2014 at 8:28 PM
Now I understand. read_model(p) is a function [m, ss] = read_model(P). When I load the file for reading model I meet error such
m = model('model_30.model','assign', P); Error :Undefined function or variable 'P'. I thihk if I try to change the function varargout = ss_eq(varargin) in
function P= ss_eq(P), the model can run.
Jun 7, 2014 at 10:47 PM
Regretfully nor this variant did not work. Am running out of ideas. I'll rewrite the code as I get mind. :(
Jun 8, 2014 at 7:27 AM
Today is a new day. Function is running. The problem was: every time put: clear all, and clc. New challenge: add the shock and forecast. All is new for me. I hope community help me, is case of critical problem. :)
Jun 8, 2014 at 8:04 AM
I have a problem. In IRIS manual is written for do this: function !switch...!case...!otherwise...!end
!switch Expression
!case Balue1
!case Balue2
In program is written the folowing:
function OUT = set_std(flag)
!switch flag
!case 'demand'
    OUT = d;
!case 'supply'
    OUT = s;
!case 'productivity'
    OUT = pr;
!case 'policy'
    OUT = p;
!case 'financial'
    OUT = f;
!case 'all'
    OUT = a;

It is like in manual, but the error is:
'case' is not recognized as an internal or external command,
operable program or batch file.
'case' is not recognized as an internal or external command,
operable program or batch file.

and so on.

What you recomend to change?

Please, help me.
Jun 9, 2014 at 7:40 AM
In MATLAB, the bang (!) is used to invoke a system command in MATLAB code. Model files are NOT MATLAB code, but use the IRIS model file language and pre-processor language described in the IRIS Manual. In this context the bang (!) is used to indicate the structure of the model file and execute pre-processor commands. The error you are getting is because you are trying to evaluate some IRIS model file code as MATLAB code, which naturally doesn't work.